An error occurred during compilation

There is a complication error in Ubuntu.I tried to floow the step of Docker - CB-Geo MPM user doc. However the error occurred when I executed one line of code: From the mpm directory, compile the source code using: mkdir build && cd build && cmake -DCMAKE_BUILD_TYPE=Release …


Then I tried this code:git clone GitHub - KaHIP/KaHIP: KaHIP -- Karlsruhe HIGH Quality Partitioning. && cd kahip
sh ./compile_withcmake.sh
However another error occurred:

Now I can’t clean the “build” fold, and I really don’t know how to solve this.

Hi @Yizhi

The mkdir build/ portion of your final command is trying to make a new subdirectory called build/ but this subdirectory already exists from previous compilation attempts. You can use ls see a list of all subdirectories and files that exist within ~/mpm/.

Now that you have all dependencies installed (e.g., KAHIP), I think the simpliest thing would be to just completely remove the existing build/ subdirectory and follow CB-Geo compilation steps from the beginning one more time.

If you’re in ~/mpm/ you can remove the build/ subdirectory with:

rm -rf build/