HYDU_parse_array error on TACC

I compiled the code based in the hotfix/key_not_found. The following commands were used to compile it:

module load intel/18.0.2
export CC=icc
export CXX=icpc
cmake -DBOOST_ROOT=$TACC_BOOST_DIR -DBOOST_INCLUDE_DIRS=$TACC_BOOST_INC -DCMAKE_BUILD_TYPE=Release -DEIGEN3_INCLUDE_DIR=$HOME/eigen -DKAHIP_ROOT=$HOME/KaHIP/ -DHALO_EXCHANGE=Off ..
make -j

When trying to run on TACC’s Stampede2, I get the following error:

TACC:  Starting up job 6027409 
TACC:  Starting parallel tasks... 
[mpiexec@c456-051.stampede2.tacc.utexas.edu] match_arg (../../utils/args/args.c:254): unrecognized argument i
[mpiexec@c456-051.stampede2.tacc.utexas.edu] HYDU_parse_array (../../utils/args/args.c:269): argument matching returned error
[mpiexec@c456-051.stampede2.tacc.utexas.edu] parse_args (../../ui/mpich/utils.c:4770): error parsing input array
[mpiexec@c456-051.stampede2.tacc.utexas.edu] HYD_uii_mpx_get_parameters (../../ui/mpich/utils.c:5106): unable to parse user arguments

Usage: ./mpiexec [global opts] [exec1 local opts] : [exec2 local opts] : ...

Intel(R) MPI Library for Linux* OS, Version 2018 Update 2 Build 20180125 (id: 18157)
Copyright 2003-2018 Intel Corporation.
TACC:  MPI job exited with code: 255 
TACC:  Shutdown complete. Exiting. 

The script used to submit the job was:

#!/bin/bash
#SBATCH -J t1-k20t        # job name
#SBATCH -o t1-k20t.o%j   # output and error file name (%j expands to jobID)
#SBATCH -N 2              # number of nodes requested
#SBATCH -n 8              # total number of mpi tasks requested
#SBATCH -p normal         # queue (partition) -- normal, development, etc.
#SBATCH -t 1:00:00       # run time (hh:mm:ss) - 18 hours
#SBATCH -A Material-Point-Metho
# Slurm email notifications
#SBATCH --mail-user= user.email@utexas.edu
#SBATCH --mail-type=begin   # email me when the job starts
#SBATCH --mail-type=end     # email me when the job finishes
# run the executable named a.out
module load intel/18.0.2
ibrun $WORK/mpm/build/mpm -f $SCRATCH/path/to/files -i mpm.json

At last, the list below indicate the loaded modules:

login2.stampede2(473)$ module list

Currently Loaded Modules:
  1) git/2.24.1      3) cmake/3.16.1   5) TACC           7) libfabric/1.7.0   9) python2/2.7.15
  2) autotools/1.1   4) xalt/2.8       6) intel/18.0.2   8) impi/18.0.2

Could you please load impi in your submission script:

module load impi/18.0.2

I am still getting the same error.

Are you compiling and running with impi? and could you try to run on Stampede2. I’m unable to reproduce the issue.

Thank you. The problem is solved. I indeed had to compile it with the impi. After that, the code compiled and ran with MPI.

@thiagordonho Can you load the impi/18.0.2 with module load impi/18.0.2 directly? I can’t load it as:

login1.ls5(1125)$ module load impi/18.0.2
Lmod has detected the following error:  The following module(s) are unknown: "impi/18.0.2"

Thiago was running on Stampede2. The issue of impi is on LS5. On LS5 you should run:

module load impi-largemem

Thanks. I wll try again.