No VTK outpus when set vtk in the json input file

Hello, @jgiven100
After I set “vtk” positive in the .json file, there is no .vtp files output in the results folder.
Any suggestions?
[following is what I set in the input file]

"post_processing": {
    "output_steps": 50,
    "path": "results/",
    "vtk": [
      "stresses",
      "strains",
      "velocities"
    ],
    "vtk_statevars": [
      {
        "phase_id": 0,
        "statevars": [
          "pdstrain"
        ]
      }
    ]
  }

Hi @fengzk

Please consider checking out my recommendation from before:

In the post I reference, @kks32 offers 2 options:

  • Compile without VTK
  • Manual install of VTK

Based on your response

I tried to comment the “find package(VTK)” in the CMakeLists.txt, but there is still the errors.

it appears you have selected to comment out this section and compile without VTK. If you want these outputs, please consider a manual install of VTK instead of compiling without VTK. Alternative approach could be to use the HDF5 output.