Partio could not be found/configured. (missing: PARTIO_LIBRARIES)

Hi,
When I do
cmake -DCMAKE_CXX_COMPILER=g++ -DKAHIP_ROOT=~/workspace/KaHIP -DPARTIO_INCLUDE_DIRS=~/local/include -DPARTIO_LIBRARIES=~/local/lib ..
I get the following:
-- Partio could not be found/configured. (missing: PARTIO_LIBRARIES)

I installed Partio following https://github.com/wdas/partio. I noticed that it was installed at ‘~/local’. Under this directory, the “partio.h” is under ‘./include’. There is a shared library “libpartio.so” under ‘./lib’.

Can I modify the “FindPartio.cmake” to make it work? Do I need to recompile the Partio?
Thank you!

Hi @JiaweiChenKodomo

What about trying -DPARTIO_ROOT=~/workspace/partio as described here?

Also, what will you be planning to use partio for?

Hi,
Thank you. I tried
cmake -DCMAKE_CXX_COMPILER=g++ -DKAHIP_ROOT=~/workspace/KaHIP -DPARTIO_ROOT=~/workspace/partio ..
However, I still get the following error:
-- Partio could not be found/configured. (missing: PARTIO_LIBRARIES)
I also tried the command in the link you posted and got the same error.

Does it have anything to do with line 25-27 of “FindPartio.cmake”, which reads:
find_library(PARTIO_LIBRARY partio DOC "Directory where the Partio library is located" ) ?

I plan to use partio to generate bgeo files for Houdini.
Thank you.

Hi @JiaweiChenKodomo

When you installed Partio could you install it in ~/workspace/partio? To install partio:

    prefix=$HOME/workspace/partio/
    git clone https://github.com/wdas/partio.git
    cd partio
    make -j prefix=$prefix install

Also, you only need to install Partio if you plan to render the simulations using Houdini or Renderman, otherwise, VTK files can be used for visualization.

(edit): Sorry just saw your comment on bgeo files for Houdini.

Hi, Thank you. I have installed it in ~/workspace/partio. However, the problem persists.

I wonder what a successful Partio installation look like? Should I see a shared library called “partio”? (Is this what “FindPartio.cmake” expects?)

Currently, I can only find a “libpartio.so” file and a folder related to python under the \lib directory. Under \bin, there are a few more libraries, but none of them named “partio”.

Hi @JiaweiChenKodomo

So I tried the method suggested on wgas/partio page and that doesn’t work. Instead, please use the method suggested in the cb-geo/mpm readme for installl Partio https://github.com/cb-geo/mpm#partio-for-houdini-sfx-visualization.

Please delete the ~/workspace/partio you have already created. Then do the following:

mkdir -p ~/workspace && cd ~/workspace/ && git clone https://github.com/wdas/partio.git && \
    cd partio && cmake . && make

Once this is done, use cmake -DPARTIO_ROOT=~/workspace/partio in addition to other cmake commands and see if cmake is able to find the partio libraries. This method works for me.

@JiaweiChenKodomo did the above workaround fix your issue?

Yes. Thank you so much!