Problem in using the MPM3D (old) code

I have install the MPM code following the guidance in Linux(ubuntu) , and then I create all files needed of the testing example “element_testing” , which are all same as the ones shown in “”. However, when I run the input files in the MPM code, it’s not work.
After I input the command “./mpm -f element_testing”, the command windows shows “analysis started, Model properties: dimension=2 , dof = 2 , Nodes =4”. But immediately stop and shows " Segmentation fault(core dumped)", and there is no result files or log files created.

Is that caused by some problem of my computer or my Linux system?

Thanks for your help, and looking forward to your reply.

Hey! Can I ask whether you put in in folder bin? So if you put it in mpm-3d/bin/element_testing/inputFiles you have to run ./mpm -d bin -f element_testing. If this does not work, could you please send me the input files? Enjoy!

Thanks for your help, but after I run ./mpm -d bin -f element_testing, it still not work, and shows that “Loading input files from: binelement_testing
(EE) Assertion of “inputFile.is_open()” in function “int main(int, char**)”,
(EE) line 149 of file “cartesian/src/main.cpp” failed!
Give up(core dumped)”
The input file has been send to you by e-mail, Thanks again.

Oh. I am sorry. Coukd you try ./mpm -d bin/ -f element_testing. If not, can you upload the input files to me? Thanks!

I have try “./mpm -d bin/ -f element_testing”, but it still shows
" Two-Dimensional Material Point Method
University of Cambridge - Version 0.1.2

Loading input files from: bin/element_testing

Analysis started at: Wed Apr 25 09:40:18 2018

Model properties: dimension = 2 , dof = 2 , Nodes = 4
Segmentation fault(core dumped)"
Only pictures can be upload in this forum, so could I send the input file to you by e-mail?
Thank you so much.

Alright. You can email me. Or you can put a link using dropbox or google drive here.

I have enabled other upload extensions, please let us know if you have any problems. Please have all the information in a single location.

input.dat (982 Bytes)
initStressSoilP.dat (145 Bytes)
material.dat (134 Bytes)
soilParticles.dat (133 Bytes)
mesh.smf (141 Bytes)
Traction.dat (73 Bytes)
submesh.dat (12 Bytes)

Thank you so much, I have upload my input files.

You are missing mesh.constraint part I think! Maybe make that?

Sorry,this file is not able to upload, the following picture contain the information of it

The quickest way is for me to try to run. Can you please just zip all the files and send it to me. I will try right now! Thanks! (2.7 KB)
Thank you so much

I think I know where.

In mesh.smf file, please delete all your comments on lines 4 and 8. Let me know whether it works. It works for me.

:sob:It doesn’t work for me, and still the same problem

Can you show me the error message?

"已放弃(核心已转储)"means :Give up(core dumped)

Could you share with us a screenshot of running the command ls on the mpm-3d-master directory?