Problems to compile Kokkos

Hello guys, I’ve already cloned kokkos in my docker container but when I tried to compile it I got the following error messages:

I have the 2.8 Cmake version so should I update it to the 3.10 version?
And How can I overcome the first error about the tribits_supackage?

could you please help me?

Please provide more details on the docker image you are using? and the steps involved in compiling KOKKOS.

Thanks for replying,
I used the docker image
Then I cloned KOKKOS by using git clone
and used the command cd cmake_build/ cmake -DCMAKE_BUILD_TYPE=Release … to compile it but it did not work

Could you share the output of cmake command. Also, make sure you are running cmake in build directory.

Try Run the following steps to compile KOKKOS

  • Clone KOKKOS: git clone
  • cd kokkos and mkdir build && cd build
  • Run Cmake cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_COMPILER=g++ ..
  • Compile using make -j.

Please share the CMake and make file logs.

Thanks for replying,
I tried by using this command sudo docker pull
But I got the next error message
Error response from daemon: Get name invalid: Nested repositories are not supported.
What shall I do?

To pull the Kokkos image, you need to do sudo docker pull not sudo docker pull

I think it worked

Thank you so much