Running LEM code on Lonestar5

Hi, I’m having some quick questions about using Longstar5.

  1. For some modules (e.g. Eigen3, Boost…) that I loaded directly from Longstar using module load, they cannot be found by cmake. Then I installed these modules locally using Spack and loaded them, they can be found. I used the same command cmake -DCMAKE_BUILD_TYPE=Release .. for both cases. Just wondering why this difference happened?

  2. As command (776) shows, when I try to load modules installed locally using Spack, the module load cannot recognize /path/to/module. Instead, I have to change to the installed directory and load the module (command (774) and (777)).

This caused problems when I wrote script in ~/.bashrc to automatically load those modules as I login. I wrote following command in ~/.bashrc, first change to the installed directory and then load the module,

But it gives following error. It seems using those command in ~/.bashrc, the module still cannot be found, even though it already changed to target directory. Then it can be loaded if I manully input the command as (777)

Anyway my problem is, how can I make it automatically load the local installed modules as I login?

  1. There is a parameter -n in the example job scrip. Not quite sure what does the ‘total_task’ means here? Is it only for mpi task? Then is n=1 if I do not use MPI, even though I may use TBB or something else?


Thanks.

Hi @zs0930

Please use the module BOOST available on TACC. You can install Eigen manually in the home directory.

cd $HOME
module load boost hdf5 vtk
export LD_LIBRARY_PATH=$SWR_LD_LIBRARY_PATH:$LD_LIBRARY_PATH
wget http://bitbucket.org/eigen/eigen/get/3.3.7.zip
unzip 3.3.7.zip
mv eigen-eigen* eigen

Once that’s done, you can call them as:

-DBOOST_ROOT=$TACC_BOOST_DIR -DBOOST_INCLUDE_DIRS=$TACC_BOOST_INC  -DEIGEN3_INCLUDE_DIR=$HOME/eigen

Yes, please use N1 and n1 for the number of MPI tasks.